Anyone rebuilt a 4L60E transmission?

Transmission to Rear-end

Moderator: Team

ingram
Member
Member
Posts: 141
Joined: Fri Nov 30, 2012 7:22 pm
Location: Georgia
Contact:

Re: Anyone rebuilt a 4L60E transmission?

Post by ingram » Wed Oct 08, 2014 12:24 pm

Here are a couple of pictures to show what I was talking about.
Attachments
Stand.jpg
inverted stand
Ramps.jpg
Rhino Ramps
Ingram Engineering
Cam Profile Designs
www.camprofiledesigns.com

TexasT
New Member
New Member
Posts: 19
Joined: Sat Aug 02, 2014 5:47 pm
Location: Texas

Re: Anyone rebuilt a 4L60E transmission?

Post by TexasT » Sat Oct 18, 2014 11:47 am

Good stuff there.

I I put mine on the engine stand for pulling the vb and then layer to put the vb and servo in(and out and in a few times while we got the clearance on the band we wanted).

Image

But for pulling the pump and such I put the case tail down in a five gallon bucket to catch the fluid. Then after we got the bare case clean I made a bracket to clamp it to my work bench for reassembly.

Image

Image

Just a piece of angle iron drilled to fit a couple pan bolt holes and c clamped to the bench. See my catch bucket there.
Make sure your bench will be sturdy enough to hold it up once you fill it .

Looks like you are making good progress. Keep up the great work.
Rich

wyrmrider
Guru
Guru
Posts: 6932
Joined: Thu Jan 10, 2013 10:52 pm

Re: Anyone rebuilt a 4L60E transmission?

Post by wyrmrider » Tue Apr 14, 2015 3:40 pm

Cheep ramps collapse, once the car's up put some stands under it also for backup

Post Reply