Need help 2003 ford 4.6 idles high?

Tech questions that don't fit above forums

Moderator: Team

Post Reply
drifter
Expert
Expert
Posts: 658
Joined: Sat Oct 22, 2005 3:42 pm
Location: Some where in this world

Need help 2003 ford 4.6 idles high?

Post by drifter » Fri Jun 07, 2013 6:14 pm

I have a 2003 explorer with a 4.6 engine it has 150,000 kilometers we have had it 2 yrs or so and I always thought it idled a bit high.this is what its doing now when you are slowing down the trans mission downshifts into first hard just before you come to a stop which i'm sure is from the high idle ok and just yesterday when we got home it was 1500rpm in park never did that before today I put a new IAC no change then a new tps nothing with my little scan tool at idle it says Absulute TPS % 18 so I took the 2 tps screws out and turned it back and it was ready 14% at idle and then the engine idles perfect approx. 620rpm the so for now I sloted the tps holes and the scanner says absolute tps 14% at idle and it seems fine I took it for a ride the trans might be shifting a little early now or it was just shifter slower before but it seemed great Now I know this is not a correct way to fix this problem so my question is what the heck is the problem?
there is no vac leaks in the pcv boot or any leaks that I can find but I will tell you the muffler has a big hole or is split and getting louder lately

drifter
Expert
Expert
Posts: 658
Joined: Sat Oct 22, 2005 3:42 pm
Location: Some where in this world

Re: Need help 2003 ford 4.6 idles high?

Post by drifter » Fri Jun 07, 2013 7:33 pm

Just took it out for a 45 min drive the trans seems normal the way it shifts to me now might have been just me.But it idles perfect no engine lights on so I don't know why lowering the tps value solved the problem

drifter
Expert
Expert
Posts: 658
Joined: Sat Oct 22, 2005 3:42 pm
Location: Some where in this world

Re: Need help 2003 ford 4.6 idles high?

Post by drifter » Sat Jun 08, 2013 10:04 am

Of coarse the wife takes it out today and calls and says its stalling now

jake197000
Pro
Pro
Posts: 212
Joined: Sun Mar 18, 2012 11:37 pm

Re: Need help 2003 ford 4.6 idles high?

Post by jake197000 » Tue Jun 11, 2013 10:31 pm

disc. iac it should idle way down if not you got a leak or the throttle is open too far.clean the throttle body also.ck the tps voltage it should be about .8 to.9 volts.much above that and computor considers it off idle.that percent load at idle is bs.use voltage.hope it helps.

PHANTASM
Member
Member
Posts: 105
Joined: Thu Aug 11, 2011 12:19 am
Location: minnesota

Re: Need help 2003 ford 4.6 idles high?

Post by PHANTASM » Fri Oct 11, 2013 1:04 am

CHECK YOUR PCV VALVE just had one of these and the pcv valve spring was weak and allowing a vac leak to happen.

EthylCat
Pro
Pro
Posts: 232
Joined: Wed Jul 12, 2006 12:02 pm
Location: Midwest
Contact:

Re: Need help 2003 ford 4.6 idles high?

Post by EthylCat » Wed Nov 06, 2013 12:22 pm

How carboned up is the throttle?

If the tps was that high I would have guessed that the blade was stuck partially open.

You adjusted the tps and now the blade has settled back. (stalling)

Anything above about 1.1v from the tps is considered "part throttle" and the pcm commands the iac open to catch the engine and bring it to idle when the throttle is closed.

justahoby
Guru
Guru
Posts: 1060
Joined: Sat Oct 22, 2011 1:28 am
Location: Temporarily in Stephenville, Texas, USA from Thunder Bay, Canada
Contact:

Re: Need help 2003 ford 4.6 idles high?

Post by justahoby » Tue Nov 12, 2013 10:24 pm

I have seen the idle air solenoid on a 1999 company vehicle I drove act up.. It was a 4.6l in a f250 (7lug wheel) weirdo heavy half like pos....idle high one day... Second day stall every ther time it stopped... I think we switch out the solenoid or throttle body.. Cant remember was a long time ago... And I sunk the POS in a river in 2003.. Boss almost fired me :lol:
As I'm approaching 40,I still think I'm 20. What the hell is wrong with me?

Post Reply